Frozen on Startup



  • I received my Frontrow 2 days ago, worked fine the first few times I booted up and paired it. This morning though, it's stuck on the "crown" opening screen and will no longer respond. Tried long press of the power and it will not shut off.
    It's been on for 40+ minutes now and warm to the touch.
    I contacted customer service via the web portal and they claim there is no way to hard reset the camera?!? They said they had to consult their team and would email me a response.. In the mean time while I wait, I grow more concerned of screen burn of this simple image and battery overload.
    At this point I'm hoping the battery just runs down and it shuts off once the charge is gone, but seems pretty terrible to design something without a hard reset button combo for instances like this. Other hardware manufacturers have built this safety function in for decades.
    Not a great first impression.


  • administrators

    This post is deleted!


  • @jeffwickliffe1 Have you tried to hold the power button for 10+ seconds to force a reboot?



  • Hello, This is Jack with FrontRow support. Thank you for bringing this to our attention! Have you reached out to our support channel yet? We would love to get in touch HERE: https://help.frontrow.com/hc/en-us



  • @eddie-crawford Although my screen is not frozen I have tried to hold the power button for +10sec but the system does not reboot by itself.

    The only way to reboot is when your camera is fully functional and you press the power button for either "power off" or "reboot" option.


Log in to reply
 

Looks like your connection to FrontRow Community was lost, please wait while we try to reconnect.