Pairing is a Nightmare



  • I'm calling this a bug. I use a wide variety of Bluetooth devices, and know how to pair devices and all the things to try when it doesn't work. The FrontRow continues to be more frustrating than productive to me because it will not pair/stay paired to several devices:

    • iPad Pro
    • Motorola G4+
    • iPhone 6
    • Google Nexus tablet (2013)

    I'm trying to get FrontRow (B024) FROS 1.7.11 Firmware 1.4.349 Hardware rev18 to reliably connect to ANY of these devices, one at a tiime, for days on end. The pattern is the same on all devices, regardless of rebooting both device and FrontRow, restarting the FrontRow app, disabling/re-enabling Bluetooth, whatever. On all devices, when you go to pair:

    • May or may not see FrontRow in the list of devices
    • When you do see it, pairing might work 1 out 20 times
    • When you do see it, you get the prompt on computing device and FrontRow to pair, but when you tell it to pair, FrontRow immediately goes back to scanning while the other device is trying to pair.
    • Once in a great while it works
    • I have no problems whatsoever using a range of other Bluetooth devices on the same devices that struggle with FrontRow.

    After months of fighting this, I'm finding I idon't want to use or recommend FrontRow. I could forgive the Bluetooth headaches if you were allowed to access it's stored files via the USB cable, but as is I could spend hours never getting a good pairing and not able to get files off of FrontRow.

    Am I the only one dealing with this?


  • administrators

    Can you help to feedback both device and phone end ?

    What’s the model of your phone ?

    Thanks


  • administrators

    Did you try FrontRow Cloud ? https://cloud.frontrow.com/
    It can help to download video/photo temporarily .



  • @vincentqiu as mentioned above, Motorola G4 (Android) and iPhone 6, along with the tablets shown. They all have the same behavior from the FrontRow.



  • @vincent-frontrow have looked at cloud, and if no other option will use it. But also seems like Bluetooth should be expected to function. If no one else is having problems, it may be one problem unit. But Bluetooth pairing is unequivocally a problem on this FrontRow.



  • @Wirednot
    Connect to the USB can use PTP, if you use osx operating system, you can connect USB and then open the Launchpad->photo,It can help to download video/photo temporarily .

    0_1517283666020_111111.png



  • Thanks for the info, Arvin. I use OS X at work, not usually at home and certainly not mobile when you'd most want to use Front row. But that is good to know (also needs to work with Windows that way).

    I just factory defaulted it again, tried to connect on different Android phone, and different iPad. Front row shows "scanning", other devices don't see Front row at all or very, very briefly. Feels like defective radio if no others act this way.



  • @wirednot if FrontRow has bound to one Phone, it will be invisible to other phones unless you unbind device on phone(FrontRow App Client - > Settings -> unbind device) or logout account on FrontRow(Settings->Account->Logout).



  • @jabinzhao thanks, i’m Good with all that as well. Between trying devices, was also factory resetting FrontRow, and making sure last device not paired.

    Now it gets weird. I have done Factory Reset” probably 15 times trying to find a device in my mix that will reliably pair, spanning at least 2/possibly 3 code updates to FR. The very last factory reset acted different. The only way to describe it is that it actually acted like a factory reset, sending the unit truly back to stupid (Good stupid). Need to set date, time zone, etc. By contrast, I realize now that each previous attempt on Factory Reset has shown none of this and has acted like simple Reboot in that power has gone off/on, but never then prompted for language, EULA, time, etc.

    Now, so far, Front Row paired right up to my preferred phone. To test sanity, I broke that pairing, tried it on iPad. Behaved exactly how you would want. Broke that pair, got repaired to preferred phone easy. Then for scientific curiosity, did factory reset again. Trouble again.

    This factory reset presented the starting flow, but after Wi-Fi (which I skipped) it just started up as if factory restart had completed. Then no pairing... do another factory reset, went all the way through. Let’s go for another- this factory reset acted like a simple reboot.

    So- when that reset goes all the way through, it’s good and predictable. But when it doesn’t, which is often for whatever reason, the end result with pairing is really erratic.


Log in to reply
 

Looks like your connection to FrontRow Community was lost, please wait while we try to reconnect.